Headset Feedback While Using PTT

I am having an issue… I have a Lightspeed Zulu 2 and when I PTT, I am getting a great deal of feedback. It is noticeable by myself, occupants and whomever is on the receiving end (CTAF, Tower, etc). It only happens when PTT is held.

I have already gone an reduced the mic gain and no improvement. I did a quick search, and it looks like this issue, while not super common, has happened for others, including Lightspeed Zulu users.

The 2007 Cirrus SR22 airplane I fly uses GTN 650/750 navcom setup. We have also confirmed the cabin speak is off.

Any ideas what might be going on? Really frustrated by this.

Zulus are famous (infamous?) for requiring the headset’s #1 dip switch to be set to stereo. But normally that issue means the headset does not work at all, so probably that is not it.

For diagnosing, have you tried plugging the headset into the copilot position and see if the problem persists when using the right PTT? If you still get the static, have you tried a different headset?

When you say “feedback” do you mean a squeal/high pitched noise, or what?

As Jim said, try the copilot side and a different headset. Other elimination points - is it the same on both radios? What happens when you turn off the audio panel (should failover to COM1 in that case.)

If the problem only occurs with the one headset, on both radios and both sides, and whether the audio panel is off or on, then it’s gotta be a headset problem and you should send it back for warranty repair. If it’s not as clear cut as that but not obviously any other item of equipment it would be worth calling Lightspeed anyway.

Finally, you would have been better posting in the Avionics forum rather than the guest forum. Not everybody reads this one.

Thanks Clyde. Still getting use to these forums and how/where to post. I am new here.

It is a high squeal. Think your stereotypical “mic on stage” feedback. Very high pitch.

I am going to try plugging into co-pilot seat and trying the PTT and see what happens. I appreciate the feedback (no pun intended)


YES! When I first started flying the Cirrus, I was not able to hear anything. Took me some Reddit and forum browsing to figure out I needed to switch one of the dip switches. So, that is done and not the issue

As I mentioned to Clyde below, I am going to try plugging into co-pilot and using that PTT and see how it reacts.

Just as a reference, here is another forum/post that mentions the same issue (with no real solution other than returning to Lightspeed and getting a “new” or “fixed” one).

Overhead speaker on?

No, we confirmed it is not on.

Is there any issue when just talking on the intercom?

I doubt this issue is the headset itself. Also be sure no other headsets are connected while doing your further tests.

No issue at all when just speaking withing the cabin (intercom). Only when using PTT

Well that muddies the waters about it just being a problem with the headset. The mic is the same in both cases.

Here’s another question - does it depend on what frequency you are transmitting on? RF being coupled into the audio circuit can cause what you’re describing. A bad earth on the mic circuit somewhere is a potential cause - a bad headset cable could cause that, and it would be consistent with not being affected on intercom (when no RF is being generated.)

It could also be an issue with the aircraft wiring which is why comparing headsets and sides matters.