Having difficulty with the “back” arrow when viewing the site on an iPad

Having difficulty with the “back” arrow when viewing the site on an iPad. When pressed, the site does not go back to the previous screen but almost locks up and then defaults to the introductory screen. Thanks.

Hello Lewis-

I am unable to recreate this anomaly on my iPads, would you please share your iPad & iOS versions and whether or not you are using the default Safari browser?

By introductory screen, are you referring to your forum “Default Home Page” or does your browser crash and return you to the iPad home screen?

Hmmm, not sure of the problem but the back button works on my iPad. IPad Pro 10.5 on iOS 14.4. It has worked properly since we changed to the new site.

It seems no one else is having this issue on their iPads. When that is the case, the first thing to do is shut down the iPad and restart. That “cures” a large degree of those types of issues. You may want to start by simply closing and re-opening Safari or whatever web browser you are using.

There are reported issues with the back button and ‘swipe back’ function on iOS devices in the Discourse knowledge base dating back to early releases of iOS 11, however those appears to have been solved with later releases.

I don’t see mentions of this anomaly related to any of the recent iOS software releases.

I have the same issue. The site hangs when using the back arrow on Safari.

iPad Air v4
ios 14.4

Hmmm, didn’t know that. I generally keep my iOS devices up to a fairly recent version.

I lag a bit when a completely new iOS comes (a X.0) out to let the bugs get solved. FWIW, Apple has gotten awful in SW quality control, IMO. So I updated to iOS on my iPhone in January when it was up to 14.4. I did my iPads earlier, but not immediately either. But I don’t usually go more than a few months.

I am.

Tried that, it didn’t help.

The workaround is to avoid using the back button, and clicking on the COPA Logo. It’s a. It if a pain, as it adds another click to get to “new” or “unread”.

Thank you Jorge-

I can’t recreate the issue on either of my iPads (iPad mini 5 & iPad Pro 4th Gen) both running 14.4, I will research this issue further and report back.

I’m having the same issue on my iPhone 12 (14.4). It just started yesterday and continues today.

The only change we made on our end recently was to add code to include the banner for the SUN 'n FUN 2021 COPA Luncheon, this is the first time we add that to the site, although I can’t see how it would, perhaps that caused this issue.

I have temporarily removed the code, would those of you experiencing the “back button” issue please clear your browser cache and report back if the condition persists or was resolved.

My back button works fine now. Thanks.


I returned the banner code to the desktop site only, when you get a chance, would you please confirm if this affected the function of the back button on your iPhone please?

Still working fine. Thanks!

Still hanging up after a hard boot on iPad Pro running version 14.4.


I removed the banner code altogether, it is apparently not stable, would you please let me know if that fixed your issue, also are you using Safari (or another browser) or the Discourse app?

Back button works for me now!

Safari, btw

I had the same issue on my iPhone for the past couple days. Works fine now that the banner is gone. Thanks -

Don’t thank me, I’m the one that broke it in the first place. :unamused:

Discourse theme components, as I have come to discover, can be unpredictable, the banner has been removed, and this issue should be resolved.

If anyone else experiences this issue please clear your cache and report back if the problem persists.

1 Like