JeppFD Charts App Unusable?

Is anyone having the same issues with JeppFD on an iPad2? It worked just fine until I downloaded the latest IOS and the latest App update. Now the App crashes/ does not start up/ does not respond/all of the above. Jeppesen is unable to offer any advice that fixes the issues other than telling me to spend big money on the latest iPad.

Surely I am not the only person on earth with this problem?


You don’t need the latest and greatest iPad. It works fine on my Air. You probably could find a used Air cheap.

Why don’t you join COPA and come discuss with Jeppesen on their Ask Jeppesen forum?

If you fly a Cirrus, you should be a COPA member.

Hi Guys,

Thanks for the advice!

I received another response from Jepp with instructions to delete from within the app as well as externally deleting the app and then reloading the app and all the data. At the moment that seems to have worked. Hope it holds after I’ve used other apps. While it’s working, the response speed is good so the iPad2 seems to have enough guts to handle the app. I’m just concerned that there seems to be a “memory leak” or some other programming error that causes it to s performance to deteriorate.

Thanks again


Glad to hear that Jepps reached out to you; they are a major supporter of COPA and its programs. As a member, you get a direct line to a dedicated support person as well as a 15-for-12 month subscription deal on various Jepps products. Not to mention tons of other ways to support your Cirrus flying habit. Like many others say “it’s the most valuable $65 I spend a year on flying.”

Be safe and have fun,

Hi Guys,

I need to post an apology…the very useful reply I received in fact came from COPA member Brian Turrisi and not from Jepp. My confusion after trying Jepp USA as well as Jepp Europe.

Many thanks Brian!


What John says, and don’t call us “Shirley” [;)]