SR-22 Avidyne - Avionics Anomaly - Pls Help


Has anyone got any knowledge on this problem please!

My G430/Avidyne setup works perfectly with the following exception:
When I select “OBS” on the No.1 or No.2 radio and GPS1 or GPS2 on the PFD, the OBS line appears on the HSI on the PFD. However the CDI on the HSI only responds intermittently to twisting the left knob on the PFD. The CDI sometimes also “drifts” slowly around the HSI dial. Physically removing and swapping the radios does not alter the situation.

With “VLOC1/2” selected on the PFD and “NAV” on the radios, the CDI responds to twisting the knob and navigates correctly.

So…do I have a hardware problem or could this be caused by a software setup setting on either the radios or the PFD. Or could it be caused by an out-of-date Garmin or Avidyne software update?

If anyone has any knowledge of this, I will be very interested as my AMO is talking big bucks to remove the PFD and send it halfway across the world for inspection.

Many thanks,


Johannesburg, South Africa

Have you tried setting the course via the Garmin 430 instead of using the PFD knobs?

I find setting courses with the PFD knob to be frustrating due to the way the acceleration logic applies to the speed at which you turn the knob. However, because it behaves correctly in Radio (VLOC 1&2) mode, that does not appear to be a hardware problem.

Another question, If you don’t attempt to change the course, does the CDI remain fixed in the current position on the HSI?

I am sorry for having more questions than answers. Hopefully, someone has seen this before and can help. Otherwise, this is an interesting problem to solve.

Hi Trip,

Many thanks for your interest!

I also thought that because the VOR controls (VLOC1/2) work correctly, that the hardware is functioning correctly. As far as I can ascertain, the comms between the 430 and the PFD is a single RS232 link. However my AMO seems to think that once the signal gets to the PFD it might be taking a different route in the PFD electronics depending if its in GPS/OBS or VLOC mode? I don’t know if this could be correct?

In answer to your question:

the course display on the HSI remains centred (on course) when the “OBS” button on the radio is initially pressed, but then starts drifting (precessing) around the HSI dial shortly thereafter at about 1-2 degrees per second.

I have also notices the following:

the data displayed on the PFD, adjacent to the top left button (i.e. the GPS & OBS data) when in GPS/OBS mode, blinks every 10 seconds or so. If I spin the left bottom knob immediately after this blink, the CDI responds in the direction of the knob spin, but stops responding after a second or so. The data display then blinks again after about 10 seconds and I get another shot at spinning the knob for a second or so. (I hope that makes sense!). Its almost as though the PFD electronics is taking 10 seconds to process the knob input data before it can take input from the knob again.

I’m in the middle of my IF training and really need this function as we don’t have a conveniently located VOR nearby.

Your interest is greatly appreciated!


Hi again,

I haven’t tried setting the course directly on the radio…will give it a try



That is odd behavior. Unfortunately, I don’t have any notion as to what might cause this.

As a substitute, to continue training while you wait for guidance or a solution, you could use the Direct To feature and input the desired course in the opened dialog box. The GPS will sequence but if the waypoint that you are using is the last waypoint in the flight plan or you have a “blank” flight plan, there will be nothing to sequence to.

The above is not a fix but it would provide a workaround until you can get the PFD to behave correctly.


Great to have you reading and posting on the non-member side of COPA. As a Cirrus Pilot, strongly recommend you join COPA and get all the COPA benefits. If you are working on your IR, having access to all the paid member forums would be very beneficial to you.

FYI, the situation you describe on the PDF is not correct behavior. There is a problem with the avionics and it should be inspected by qualified technicians.

Hi John,

Yes, I really must become a paid-up member…

I do have my Cirrus AMO on the job as well as some assistance from the local Garmin agent. However its starting to look like the PFD needs to be sent to the US from South Africa and that Ill be sans aircraft for a looong time. I was just hoping someone might have bumped into a similar problem before.



Hi Trip,

Hunting around on the 'Net, I found a blog that appears to indicate that my problem is not unique and may be related to an Avidyne update/upgrade. I’ve copied the relevant part of this blog below.

Now…does anyone know how I, as an Avidyne owner and not an AMO, approach Avidyne for a fix?



With some extra time on my hands on the flight back, plenty of fuel, and the owner’s permission, I decided to fly the OAK RNAV 27L just to see how it would compare to the G1000 experience. This is where I discovered what a lot of other Cirrus pilots apparently already know - the Avidyne Entegra system doesn’t play well with the new Garmin 430W. The Entegra primary flight display cannot currently display GPS alerts, such as the turn anticipation prompts. Selecting OBS mode on the GPS also doesn’t work on the Entegra and gives an obscure RS232 data channel #4 message.


My AMO did a software upgrade on the G430’s and voila! No more problem!

…and my grateful thanks to Garmin South Africa for providing the upgrade software free of charge!




Glad to hear your problem has been solved! I’d say you saved quite a bit more than the annual (With auto-renewal) $65US membership to COPA by asking here. Maybe it’s time to renew that membership, eh? [;)]

Be safe and have fun,