Sandel HSI failure

Just made a flight that my HSI never worked on. the plane was annualed less than 10 hours ago, though im pretty sure they didn’t do any work on the HSI itself. it wouldnt ever go to GPS mode, it would just show NAV1 on the side and wouldn’t let me change it, also a big red x on the bottom of the display. After landing I pulled over on the ramp with everything running still and unplugged the fuses to try resetting it. Tried everything button combo I could push, tried turning everything off and back on multiple times. No such luck. I’ve attached a picture, this is all it would show. Anybody else have any issues with their sandel HSI?

Eli, much has been said about Sandel occasional failures. Do a search and you’ll find a wealth of information.
It may just need to be pulled out and reset properly.
Good luck.

Check if it didn’t loose its programming. I don’t have Sandel anymore, but if you press A or B (or both) when powering it up and it comes up with programming screens. Search the forums, there are pictures of correct values to program.

A few simple suggestions:

Check and see if in the annual they replaced the Sandel bulb. If they did and did. It seat the Sandel correctly it will do that. Basically the Sandel rack needs to be held from behind while seating it or some of the pins are just barely seated.

Someone mentioned settings. Has the battery died lately? Was the master left on and it killed the battery? The Sandel is very intolerant to that and will lose settings when those types of things happen.

To access the setting pages press and hold the bottom left and bottom right buttons simultaneously while powering up. Then it goes into an extensive setting page (like 26 chapters). Do not change anything without documenting things so you can undo it. I sugest all owners get in there and photo all the settings so you can reset them if a power event happens that changes settings. I don’t have all the settings with me but other owners do. Maybe they can send them to you.

This may seem like a dumb suggestion, but did you try changing the nav source on the 430?


Happens to me any time the G430 has been manually shut down using its own switch. A quick push from VLOC back to GPS fixes the Sandel.

Yeah I tried pushing the CDI button on both 430s changing it from VLOC/GPS

a bunch, didnt seem to do anything to the HSI.